Solaris 2.x/7.0/8 lpd Remote Command Execution Vulnerability

2001-08-31T00:00:00
ID EDB-ID:21097
Type exploitdb
Reporter ron1n
Modified 2001-08-31T00:00:00

Description

Solaris 2.x/7.0/8 lpd Remote Command Execution Vulnerability. CVE-2001-1583. Remote exploit for solaris platform

                                        
                                            source: http://www.securityfocus.com/bid/3274/info

The print protocol daemon, 'in.lpd' (or 'lpd'), shipped with Solaris may allow for remote attackers to execute arbitrary commands on target hosts with superuser privileges.

The alleged vulnerability is not the buffer overflow discovered by ISS.

It has been reported that it is possible to execute commands on target hosts through lpd by manipulating the use of sendmail by the daemon.

If this vulnerability is successfully exploited, remote attackers can execute any command on the target host with superuser privileges.

This vulnerability is very similar to one mentioned in NAI advisory NAI-0020.

NOTE: It has been reported that a valid printer does NOT need to be configured to exploit this vulnerability.

https://github.com/offensive-security/exploit-database-bin-sploits/raw/master/sploits/21097.tar.gz