[SECURITY] [DSA 3325-2] apache2 regression update

2015-08-18T11:39:27
ID DEBIAN:DSA-3325-2:9B1A3
Type debian
Reporter Debian
Modified 2015-08-18T11:39:27

Description


Debian Security Advisory DSA-3325-2 security@debian.org https://www.debian.org/security/ Stefan Fritsch August 18, 2015 https://www.debian.org/security/faq


Package : apache2 CVE ID : CVE-2015-3183 CVE-2015-3185 Debian Bug : 794383

The security update from DSA-3325-1 caused a regression for the oldstable distribution (wheezy). In some configurations, apache2 would fail to start with a spurious error message about the certificate chain. This update fixes this problem. For reference, the text of the original advisory follows:

Several vulnerabilities have been found in the Apache HTTPD server.

CVE-2015-3183

An HTTP request smuggling attack was possible due to a bug in
parsing of chunked requests. A malicious client could force the
server to misinterpret the request length, allowing cache poisoning
or credential hijacking if an intermediary proxy is in use.

CVE-2015-3185

A design error in the "ap_some_auth_required" function renders the
API unusuable in apache2 2.4.x. This could lead to modules using
this API to allow access when they should otherwise not do so.
The fix backports the new "ap_some_authn_required" API from 2.4.16.
This issue does not affect the oldstable distribution (wheezy).

In addition, the updated package for the oldstable distribution (wheezy) removes a limitation of the Diffie-Hellman (DH) parameters to 1024 bits. This limitation may potentially allow an attacker with very large computing resources, like a nation-state, to break DH key exchange by precomputation. The updated apache2 package also allows to configure custom DH parameters. More information is contained in the changelog.Debian.gz file. These improvements were already present in the stable, testing, and unstable distributions.

For the oldstable distribution (wheezy), this problem has been fixed in version 2.2.22-13+deb7u6.

The other distributions were not affected by the regression.

We recommend that you upgrade your apache2 packages.

Further information about Debian Security Advisories, how to apply these updates to your system and frequently asked questions can be found at: https://www.debian.org/security/

Mailing list: debian-security-announce@lists.debian.org