[SECURITY] [DLA 2085-1] zlib security update

2020-01-29T21:55:34
ID DEBIAN:DLA-2085-1:566B5
Type debian
Reporter Debian
Modified 2020-01-29T21:55:34

Description

Package : zlib Version : 1:1.2.8.dfsg-2+deb8u1 CVE ID : CVE-2016-9840 CVE-2016-9841 CVE-2016-9842 CVE-2016-9843

Several issues have been found in zlib, a compression library. They are basically about improper big-endian CRC calculation, improper left shift of negative integers and improper pointer arithmetic.

For Debian 8 "Jessie", these problems have been fixed in version 1:1.2.8.dfsg-2+deb8u1.

We recommend that you upgrade your zlib packages.

Further information about Debian LTS security advisories, how to apply these updates to your system and frequently asked questions can be found at: https://wiki.debian.org/LTS