[SECURITY] [DLA 2002-1] libice security update

2019-11-23T19:05:31
ID DEBIAN:DLA-2002-1:26155
Type debian
Reporter Debian
Modified 2019-11-23T19:05:31

Description

Package : libice Version : 2:1.0.9-1+deb8u1 CVE ID : CVE-2017-2626

It has been found, that libice, an X11 Inter-Client Exchange library, uses weak entropy to generate keys.

Using arc4random_buf() from libbsd should avoid this flaw.

For Debian 8 "Jessie", this problem has been fixed in version 2:1.0.9-1+deb8u1.

We recommend that you upgrade your libice packages.

Further information about Debian LTS security advisories, how to apply these updates to your system and frequently asked questions can be found at: https://wiki.debian.org/LTS