Lucene search

K
cve[email protected]CVE-2023-2733
HistoryMay 25, 2023 - 3:15 a.m.

CVE-2023-2733

2023-05-2503:15:08
web.nvd.nist.gov
33
mstore
api plugin
wordpress
authentication bypass
vulnerability
nvd
cve-2023-2733

9.8 High

CVSS3

Attack Vector

NETWORK

Attack Complexity

LOW

Privileges Required

NONE

User Interaction

NONE

Scope

UNCHANGED

Confidentiality Impact

HIGH

Integrity Impact

HIGH

Availability Impact

HIGH

CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

9.5 High

AI Score

Confidence

High

0.002 Low

EPSS

Percentile

59.1%

The MStore API plugin for WordPress is vulnerable to authentication bypass in versions up to, and including, 3.9.0. This is due to insufficient verification on the user being supplied during the coupon redemption REST API request through the plugin. This makes it possible for unauthenticated attackers to log in as any existing user on the site, such as an administrator, if they have access to the user id.

Affected configurations

Vulners
NVD
Node
inspireuimstore_apiRange≀3.9.0
VendorProductVersionCPE
inspireuimstore_api*cpe:2.3:a:inspireui:mstore_api:*:*:*:*:*:*:*:*

CNA Affected

[
  {
    "vendor": "inspireui",
    "product": "MStore API",
    "versions": [
      {
        "version": "*",
        "status": "affected",
        "lessThanOrEqual": "3.9.0",
        "versionType": "semver"
      }
    ],
    "defaultStatus": "unaffected"
  }
]

9.8 High

CVSS3

Attack Vector

NETWORK

Attack Complexity

LOW

Privileges Required

NONE

User Interaction

NONE

Scope

UNCHANGED

Confidentiality Impact

HIGH

Integrity Impact

HIGH

Availability Impact

HIGH

CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

9.5 High

AI Score

Confidence

High

0.002 Low

EPSS

Percentile

59.1%