logo
DATABASE RESOURCES PRICING ABOUT US

CVE-2019-12529

Description

An issue was discovered in Squid 2.x through 2.7.STABLE9, 3.x through 3.5.28, and 4.x through 4.7. When Squid is configured to use Basic Authentication, the Proxy-Authorization header is parsed via uudecode. uudecode determines how many bytes will be decoded by iterating over the input and checking its table. The length is then used to start decoding the string. There are no checks to ensure that the length it calculates isn't greater than the input buffer. This leads to adjacent memory being decoded as well. An attacker would not be able to retrieve the decoded data unless the Squid maintainer had configured the display of usernames on error pages.


Affected Software


CPE Name Name Version
squid-cache:squid squid-cache squid 2.7
squid-cache:squid squid-cache squid 2.7
squid-cache:squid squid-cache squid 2.7
squid-cache:squid squid-cache squid 2.7
squid-cache:squid squid-cache squid 2.7
squid-cache:squid squid-cache squid 2.7
squid-cache:squid squid-cache squid 2.7
squid-cache:squid squid-cache squid 2.7
squid-cache:squid squid-cache squid 2.7
squid-cache:squid squid-cache squid 2.7
squid-cache:squid squid-cache squid 3.5.28
squid-cache:squid squid-cache squid 4.7
debian:debian_linux debian debian linux 8.0
debian:debian_linux debian debian linux 9.0
debian:debian_linux debian debian linux 10.0
fedoraproject:fedora fedoraproject fedora 29
opensuse:leap opensuse leap 15.0
opensuse:leap opensuse leap 15.1
canonical:ubuntu_linux canonical ubuntu linux 12.04
canonical:ubuntu_linux canonical ubuntu linux 16.04
canonical:ubuntu_linux canonical ubuntu linux 18.04
canonical:ubuntu_linux canonical ubuntu linux 19.04

Related