logo
DATABASE RESOURCES PRICING ABOUT US

CVE-2010-1917

Description

Stack consumption vulnerability in PHP 5.2 through 5.2.13 and 5.3 through 5.3.2 allows context-dependent attackers to cause a denial of service (PHP crash) via a crafted first argument to the fnmatch function, as demonstrated using a long string.


Affected Software


CPE Name Name Version
php:php php 5.2.9
php:php php 5.2.2
php:php php 5.2.5
php:php php 5.2.12
php:php php 5.2.11
php:php php 5.2.6
php:php php 5.2.3
php:php php 5.2.13
php:php php 5.2.0
php:php php 5.2.4
php:php php 5.2.10
php:php php 5.2.1
php:php php 5.2.8
php:php php 5.3.1
php:php php 5.3.0
php:php php 5.3.2

Related