Lucene search

K
cloudfoundryCloud FoundryCFOUNDRY:ACC795AF933D0397156EB3730A4339A8
HistoryMay 23, 2022 - 12:00 a.m.

USN-5397-1: curl vulnerabilities | Cloud Foundry

2022-05-2300:00:00
Cloud Foundry
www.cloudfoundry.org
20
canonical ubuntu
medium severity
oauth2
cloud foundry
stemcells
cflinuxfs3
cf deployment
mitigation
cve-2022-22576
cve-2022-27774
cve-2022-27775
cve-2022-27776
upgrade

EPSS

0.003

Percentile

68.9%

Severity

Medium

Vendor

Canonical Ubuntu

Versions Affected

  • Canonical Ubuntu 18.04

Description

Patrick Monnerat discovered that curl incorrectly handled certain OAUTH2. An attacker could possibly use this issue to access sensitive information. (CVE-2022-22576) Harry Sintonen discovered that curl incorrectly handled certain requests. An attacker could possibly use this issue to expose sensitive information. (CVE-2022-27774, CVE-2022-27775, CVE-2022-27776) Update Instructions: Run sudo ua fix USN-5397-1 to fix the vulnerability. The problem can be corrected by updating your system to the following package versions: libcurl4-gnutls-dev – 7.68.0-1ubuntu2.10 libcurl4-openssl-dev – 7.68.0-1ubuntu2.10 libcurl3-gnutls – 7.68.0-1ubuntu2.10 libcurl4-doc – 7.68.0-1ubuntu2.10 libcurl3-nss – 7.68.0-1ubuntu2.10 libcurl4-nss-dev – 7.68.0-1ubuntu2.10 libcurl4 – 7.68.0-1ubuntu2.10 curl – 7.68.0-1ubuntu2.10 No subscription required

CVEs contained in this USN include: CVE-2022-22576, CVE-2022-27774, CVE-2022-27775, CVE-2022-27776.

Affected Cloud Foundry Products and Versions

Severity is medium unless otherwise noted.

  • Bionic Stemcells
    • 1.x versions prior to 1.84
    • All other stemcells not listed.
  • cflinuxfs3
    • All versions prior to 0.291.0
  • CF Deployment
    • All versions

Mitigation

Users of affected products are strongly encouraged to follow the mitigations below.

The Cloud Foundry project recommends upgrading the following releases:

  • Bionic Stemcells
    • Upgrade 1.x versions to 1.84 or greater
    • All other stemcells should be upgraded to the latest version available on bosh.io.
  • cflinuxfs3
    • Upgrade all versions to 0.291.0 or greater
  • CF Deployment
    • There are no fixed versions of this product

References

History

2022-05-23: Initial vulnerability report published.

CPENameOperatorVersion
bionic stemcellslt1.84
cflinuxfs3lt0.291.0