ruby, rubygem, rubygems security update

2018-12-13T20:46:01
ID CESA-2018:3738
Type centos
Reporter CentOS Project
Modified 2018-12-13T20:46:01

Description

CentOS Errata and Security Advisory CESA-2018:3738

Ruby is an extensible, interpreted, object-oriented, scripting language. It has features to process text files and to perform system management tasks.

Security Fix(es):

  • ruby: OpenSSL::X509::Name equality check does not work correctly (CVE-2018-16395)

For more details about the security issue(s), including the impact, a CVSS score, and other related information, refer to the CVE page(s) listed in the References section.

Merged security bulletin from advisories: http://lists.centos.org/pipermail/centos-announce/2018-December/023122.html

Affected packages: ruby ruby-devel ruby-doc ruby-irb ruby-libs ruby-tcltk rubygem-bigdecimal rubygem-io-console rubygem-json rubygem-minitest rubygem-psych rubygem-rake rubygem-rdoc rubygems rubygems-devel

Upstream details at: