cups security update

2013-03-01T10:31:58
ID CESA-2013:0580
Type centos
Reporter CentOS Project
Modified 2013-03-01T10:31:58

Description

CentOS Errata and Security Advisory CESA-2013:0580

The Common UNIX Printing System (CUPS) provides a portable printing layer for Linux, UNIX, and similar operating systems.

It was discovered that CUPS administrative users (members of the SystemGroups groups) who are permitted to perform CUPS configuration changes via the CUPS web interface could manipulate the CUPS configuration to gain unintended privileges. Such users could read or write arbitrary files with the privileges of the CUPS daemon, possibly allowing them to run arbitrary code with root privileges. (CVE-2012-5519)

After installing this update, the ability to change certain CUPS configuration directives remotely will be disabled by default. The newly introduced ConfigurationChangeRestriction directive can be used to enable the changing of the restricted directives remotely. Refer to Red Hat Bugzilla bug 875898 for more details and the list of restricted directives.

All users of cups are advised to upgrade to these updated packages, which contain a backported patch to resolve this issue. After installing this update, the cupsd daemon will be restarted automatically.

Merged security bulletin from advisories: http://lists.centos.org/pipermail/centos-cr-announce/2013-March/000811.html

Affected packages: cups cups-devel cups-libs cups-lpd cups-php

Upstream details at: https://rhn.redhat.com/errata/RHSA-2013-0580.html