Lucene search

K
atlassianSecurity-metrics-botCWD-5388
HistoryMay 06, 2019 - 4:06 a.m.

Crowd - pdkinstall development plugin incorrectly enabled - CVE-2019-11580

2019-05-0604:06:13
security-metrics-bot
jira.atlassian.com
13

CVSS2

7.5

Attack Vector

NETWORK

Attack Complexity

LOW

Authentication

NONE

Confidentiality Impact

PARTIAL

Integrity Impact

PARTIAL

Availability Impact

PARTIAL

AV:N/AC:L/Au:N/C:P/I:P/A:P

CVSS3

9.8

Attack Vector

NETWORK

Attack Complexity

LOW

Privileges Required

NONE

User Interaction

NONE

Scope

UNCHANGED

Confidentiality Impact

HIGH

Integrity Impact

HIGH

Availability Impact

HIGH

CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

EPSS

0.974

Percentile

99.9%

Crowd and Crowd Data Center had the pdkinstall development plugin incorrectly enabled in release builds. Attackers who can send unauthenticated or authenticated requests to a Crowd or Crowd Data Center instance can exploit this vulnerability to install arbitrary plugins, which permits remote code execution on systems running a vulnerable version of Crowd or Crowd Data Center.

Affected versions:

  • All versions of Crowd from version 2.1.0 before 3.0.5 (the fixed version for 3.0.x), from version 3.1.0 before 3.1.6 (the fixed version for 3.1.x), from version 3.2.0 before 3.2.8 (the fixed version for 3.2.x), from version 3.3.0 before 3.3.5 (the fixed version for 3.3.x), and from version 3.4.0 before 3.4.4 (the fixed version for 3.4.x) are affected by this vulnerability.

h4. Fix:

Mitigation

Atlassian recommends that you upgrade to the latest version. However, this issue can be mitigated as per the following instructions:

Stop Crowd

Find and delete any pdkinstall-plugin jar files from the Crowd installation directory and the data directory

Remove the pdkinstall-plugin jar file from <Crowd installation directory>/crowd-webapp/WEB-INF/classes/atlassian-bundled-plugins.zip

Start Crowd

Check that there are no pdkinstall-plugin jar files in the installation directory or the data directory.

For additional details, see the [full advisory|https://confluence.atlassian.com/x/3ADVOQ].

Affected configurations

Vulners
Node
atlassiancrowdRange2.1
OR
atlassiancrowdRange2.2
OR
atlassiancrowdRange2.3.1
OR
atlassiancrowdRange2.4.1
OR
atlassiancrowdRange2.5.1
OR
atlassiancrowdRange2.6.1
OR
atlassiancrowdRange2.7.1
OR
atlassiancrowdRange2.8.1
OR
atlassiancrowdRange2.9.1
OR
atlassiancrowdRange2.10.1
OR
atlassiancrowdRange2.11.1
OR
atlassiancrowdRange2.12.0
OR
atlassiancrowdRange3.0.0
OR
atlassiancrowdRange<3.0.5
OR
atlassiancrowdRange<3.1.6
OR
atlassiancrowdRange<3.2.8
OR
atlassiancrowdRange<3.3.5
OR
atlassiancrowdRange<3.4.4

CVSS2

7.5

Attack Vector

NETWORK

Attack Complexity

LOW

Authentication

NONE

Confidentiality Impact

PARTIAL

Integrity Impact

PARTIAL

Availability Impact

PARTIAL

AV:N/AC:L/Au:N/C:P/I:P/A:P

CVSS3

9.8

Attack Vector

NETWORK

Attack Complexity

LOW

Privileges Required

NONE

User Interaction

NONE

Scope

UNCHANGED

Confidentiality Impact

HIGH

Integrity Impact

HIGH

Availability Impact

HIGH

CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

EPSS

0.974

Percentile

99.9%