Lucene search

K
amazonAmazonALAS2-2023-2227
HistoryAug 31, 2023 - 10:28 p.m.

Medium: qt5-qtbase

2023-08-3122:28:00
alas.aws.amazon.com
9
qt-based clients
hsts headers
secure https connection
cve-2023-32762
amazon linux 2
yum update
qt5-qtbase
red hat
mitre

CVSS3

5.3

Attack Vector

NETWORK

Attack Complexity

LOW

Privileges Required

NONE

User Interaction

NONE

Scope

UNCHANGED

Confidentiality Impact

NONE

Integrity Impact

LOW

Availability Impact

NONE

CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:N

AI Score

5.5

Confidence

High

EPSS

0.001

Percentile

40.2%

Issue Overview:

QT-based clients may mismatch HSTS headers (Strict-Transport-Security), which would prevent the client from switching to a secure HTTPS connection as requested by a server. (CVE-2023-32762)

Affected Packages:

qt5-qtbase

Note:

This advisory is applicable to Amazon Linux 2 (AL2) Core repository. Visit this FAQ section for the difference between AL2 Core and AL2 Extras advisories.

Issue Correction:
Run yum update qt5-qtbase to update your system.

New Packages:

aarch64:  
    qt5-qtbase-5.9.2-3.amzn2.0.10.aarch64  
    qt5-qtbase-devel-5.9.2-3.amzn2.0.10.aarch64  
    qt5-qtbase-doc-5.9.2-3.amzn2.0.10.aarch64  
    qt5-qtbase-examples-5.9.2-3.amzn2.0.10.aarch64  
    qt5-qtbase-static-5.9.2-3.amzn2.0.10.aarch64  
    qt5-qtbase-mysql-5.9.2-3.amzn2.0.10.aarch64  
    qt5-qtbase-odbc-5.9.2-3.amzn2.0.10.aarch64  
    qt5-qtbase-postgresql-5.9.2-3.amzn2.0.10.aarch64  
    qt5-qtbase-gui-5.9.2-3.amzn2.0.10.aarch64  
    qt5-qtbase-debuginfo-5.9.2-3.amzn2.0.10.aarch64  
  
i686:  
    qt5-qtbase-5.9.2-3.amzn2.0.10.i686  
    qt5-qtbase-devel-5.9.2-3.amzn2.0.10.i686  
    qt5-qtbase-doc-5.9.2-3.amzn2.0.10.i686  
    qt5-qtbase-examples-5.9.2-3.amzn2.0.10.i686  
    qt5-qtbase-static-5.9.2-3.amzn2.0.10.i686  
    qt5-qtbase-mysql-5.9.2-3.amzn2.0.10.i686  
    qt5-qtbase-odbc-5.9.2-3.amzn2.0.10.i686  
    qt5-qtbase-postgresql-5.9.2-3.amzn2.0.10.i686  
    qt5-qtbase-gui-5.9.2-3.amzn2.0.10.i686  
    qt5-qtbase-debuginfo-5.9.2-3.amzn2.0.10.i686  
  
noarch:  
    qt5-qtbase-common-5.9.2-3.amzn2.0.10.noarch  
    qt5-rpm-macros-5.9.2-3.amzn2.0.10.noarch  
  
src:  
    qt5-qtbase-5.9.2-3.amzn2.0.10.src  
  
x86_64:  
    qt5-qtbase-5.9.2-3.amzn2.0.10.x86_64  
    qt5-qtbase-devel-5.9.2-3.amzn2.0.10.x86_64  
    qt5-qtbase-doc-5.9.2-3.amzn2.0.10.x86_64  
    qt5-qtbase-examples-5.9.2-3.amzn2.0.10.x86_64  
    qt5-qtbase-static-5.9.2-3.amzn2.0.10.x86_64  
    qt5-qtbase-mysql-5.9.2-3.amzn2.0.10.x86_64  
    qt5-qtbase-odbc-5.9.2-3.amzn2.0.10.x86_64  
    qt5-qtbase-postgresql-5.9.2-3.amzn2.0.10.x86_64  
    qt5-qtbase-gui-5.9.2-3.amzn2.0.10.x86_64  
    qt5-qtbase-debuginfo-5.9.2-3.amzn2.0.10.x86_64  

Additional References

Red Hat: CVE-2023-32762

Mitre: CVE-2023-32762

CVSS3

5.3

Attack Vector

NETWORK

Attack Complexity

LOW

Privileges Required

NONE

User Interaction

NONE

Scope

UNCHANGED

Confidentiality Impact

NONE

Integrity Impact

LOW

Availability Impact

NONE

CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:N

AI Score

5.5

Confidence

High

EPSS

0.001

Percentile

40.2%