Lucene search

K
amazonAmazonALAS2-2023-2036
HistoryMay 11, 2023 - 5:49 p.m.

Medium: qt5-qtbase

2023-05-1117:49:00
alas.aws.amazon.com
13
qt sql odbc driver
dos
crafted string
security advisory
update
cve-2023-24607
amazon linux 2
red hat
mitre
plugin

CVSS3

7.5

Attack Vector

NETWORK

Attack Complexity

LOW

Privileges Required

NONE

User Interaction

NONE

Scope

UNCHANGED

Confidentiality Impact

NONE

Integrity Impact

NONE

Availability Impact

HIGH

CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

AI Score

7.6

Confidence

High

EPSS

0.002

Percentile

57.8%

Issue Overview:

When using the Qt SQL ODBC driver plugin, then it is possible to trigger a DOS with a specifically crafted string

RESERVED
NOTE: https://www.qt.io/blog/security-advisory-qt-sql-odbc-driver-plugin
NOTE: https://github.com/qt/qtbase/commit/aaf1381eab6292aa0444a5eadcc24165b6e1c02d (6.4)
NOTE: https://download.qt.io/official_releases/qt/5.15/CVE-2023-24607-qtbase-5.15.diff (CVE-2023-24607)

Affected Packages:

qt5-qtbase

Note:

This advisory is applicable to Amazon Linux 2 (AL2) Core repository. Visit this FAQ section for the difference between AL2 Core and AL2 Extras advisories.

Issue Correction:
Run yum update qt5-qtbase to update your system.

New Packages:

aarch64:  
    qt5-qtbase-5.9.2-3.amzn2.0.6.aarch64  
    qt5-qtbase-devel-5.9.2-3.amzn2.0.6.aarch64  
    qt5-qtbase-doc-5.9.2-3.amzn2.0.6.aarch64  
    qt5-qtbase-examples-5.9.2-3.amzn2.0.6.aarch64  
    qt5-qtbase-static-5.9.2-3.amzn2.0.6.aarch64  
    qt5-qtbase-mysql-5.9.2-3.amzn2.0.6.aarch64  
    qt5-qtbase-odbc-5.9.2-3.amzn2.0.6.aarch64  
    qt5-qtbase-postgresql-5.9.2-3.amzn2.0.6.aarch64  
    qt5-qtbase-gui-5.9.2-3.amzn2.0.6.aarch64  
    qt5-qtbase-debuginfo-5.9.2-3.amzn2.0.6.aarch64  
  
i686:  
    qt5-qtbase-5.9.2-3.amzn2.0.6.i686  
    qt5-qtbase-devel-5.9.2-3.amzn2.0.6.i686  
    qt5-qtbase-doc-5.9.2-3.amzn2.0.6.i686  
    qt5-qtbase-examples-5.9.2-3.amzn2.0.6.i686  
    qt5-qtbase-static-5.9.2-3.amzn2.0.6.i686  
    qt5-qtbase-mysql-5.9.2-3.amzn2.0.6.i686  
    qt5-qtbase-odbc-5.9.2-3.amzn2.0.6.i686  
    qt5-qtbase-postgresql-5.9.2-3.amzn2.0.6.i686  
    qt5-qtbase-gui-5.9.2-3.amzn2.0.6.i686  
    qt5-qtbase-debuginfo-5.9.2-3.amzn2.0.6.i686  
  
noarch:  
    qt5-qtbase-common-5.9.2-3.amzn2.0.6.noarch  
    qt5-rpm-macros-5.9.2-3.amzn2.0.6.noarch  
  
src:  
    qt5-qtbase-5.9.2-3.amzn2.0.6.src  
  
x86_64:  
    qt5-qtbase-5.9.2-3.amzn2.0.6.x86_64  
    qt5-qtbase-devel-5.9.2-3.amzn2.0.6.x86_64  
    qt5-qtbase-doc-5.9.2-3.amzn2.0.6.x86_64  
    qt5-qtbase-examples-5.9.2-3.amzn2.0.6.x86_64  
    qt5-qtbase-static-5.9.2-3.amzn2.0.6.x86_64  
    qt5-qtbase-mysql-5.9.2-3.amzn2.0.6.x86_64  
    qt5-qtbase-odbc-5.9.2-3.amzn2.0.6.x86_64  
    qt5-qtbase-postgresql-5.9.2-3.amzn2.0.6.x86_64  
    qt5-qtbase-gui-5.9.2-3.amzn2.0.6.x86_64  
    qt5-qtbase-debuginfo-5.9.2-3.amzn2.0.6.x86_64  

Additional References

Red Hat: CVE-2023-24607

Mitre: CVE-2023-24607

CVSS3

7.5

Attack Vector

NETWORK

Attack Complexity

LOW

Privileges Required

NONE

User Interaction

NONE

Scope

UNCHANGED

Confidentiality Impact

NONE

Integrity Impact

NONE

Availability Impact

HIGH

CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

AI Score

7.6

Confidence

High

EPSS

0.002

Percentile

57.8%