Medium: PackageKit

2018-04-26T17:42:00
ID ALAS2-2018-1006
Type amazon
Reporter Amazon
Modified 2018-04-26T22:42:00

Description

Issue Overview:

Authentication bypass allows to install signed packages without administrator privileges
An authentication bypass flaw has been found in PackageKit that allows users without administrator privileges to install signed packages. A local attacker can use this vulnerability to install vulnerable packages to further compromise a system. (CVE-2018-1106)

Affected Packages:

PackageKit

Issue Correction:
Run yum update PackageKit to update your system.

New Packages:

src:  
    PackageKit-1.1.5-2.amzn2.0.1.src

x86_64:  
    PackageKit-1.1.5-2.amzn2.0.1.x86_64  
    PackageKit-yum-1.1.5-2.amzn2.0.1.x86_64  
    PackageKit-yum-plugin-1.1.5-2.amzn2.0.1.x86_64  
    PackageKit-glib-1.1.5-2.amzn2.0.1.x86_64  
    PackageKit-cron-1.1.5-2.amzn2.0.1.x86_64  
    PackageKit-glib-devel-1.1.5-2.amzn2.0.1.x86_64  
    PackageKit-gstreamer-plugin-1.1.5-2.amzn2.0.1.x86_64  
    PackageKit-gtk3-module-1.1.5-2.amzn2.0.1.x86_64  
    PackageKit-command-not-found-1.1.5-2.amzn2.0.1.x86_64  
    PackageKit-debuginfo-1.1.5-2.amzn2.0.1.x86_64