Lucene search

K
amazon
AmazonALAS-2020-1360
HistoryApr 20, 2020 - 7:25 p.m.

Medium: kernel

2020-04-2019:25:00
alas.aws.amazon.com
118

7.1 High

CVSS3

Attack Vector

LOCAL

Attack Complexity

LOW

Privileges Required

LOW

User Interaction

NONE

Scope

UNCHANGED

Confidentiality Impact

HIGH

Integrity Impact

NONE

Availability Impact

HIGH

CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:H

6.9 Medium

AI Score

Confidence

High

5.4 Medium

CVSS2

Access Vector

LOCAL

Access Complexity

MEDIUM

Authentication

NONE

Confidentiality Impact

NONE

Integrity Impact

PARTIAL

Availability Impact

COMPLETE

AV:L/AC:M/Au:N/C:N/I:P/A:C

0.001 Low

EPSS

Percentile

30.7%

Issue Overview:

2023-11-29: CVE-2020-27418 was added to this advisory.

A stack buffer overflow issue was found in the get_raw_socket() routine of the Host kernel accelerator for virtio net (vhost-net) driver. It could occur while doing an ictol(VHOST_NET_SET_BACKEND) call, and retrieving socket name in a kernel stack variable via get_raw_socket(). A user able to perform ioctl(2) calls on the ‘/dev/vhost-net’ device may use this flaw to crash the kernel resulting in DoS issue. (CVE-2020-10942)

A flaw was found in the way KVM hypervisor handled instruction emulation for the L2 guest when nested(=1) virtualization is enabled. In the instruction emulation, the L2 guest could trick the L0 hypervisor into accessing sensitive bits of the L1 hypervisor. An L2 guest could use this flaw to potentially access information of the L1 hypervisor. (CVE-2020-2732)

A Use After Free vulnerability in Fedora Linux kernel 5.9.0-rc9 allows attackers to obatin sensitive information via vgacon_invert_region() function. (CVE-2020-27418)

A use-after-free flaw was found in the Linux kernel console driver when using the copy-paste buffer. This flaw allows a local user to crash the system. (CVE-2020-8648)

Affected Packages:

kernel

Issue Correction:
Run yum update kernel to update your system.

New Packages:

i686:  
    kernel-tools-devel-4.14.173-106.229.amzn1.i686  
    kernel-4.14.173-106.229.amzn1.i686  
    kernel-headers-4.14.173-106.229.amzn1.i686  
    perf-debuginfo-4.14.173-106.229.amzn1.i686  
    kernel-debuginfo-4.14.173-106.229.amzn1.i686  
    kernel-devel-4.14.173-106.229.amzn1.i686  
    perf-4.14.173-106.229.amzn1.i686  
    kernel-debuginfo-common-i686-4.14.173-106.229.amzn1.i686  
    kernel-tools-debuginfo-4.14.173-106.229.amzn1.i686  
    kernel-tools-4.14.173-106.229.amzn1.i686  
  
src:  
    kernel-4.14.173-106.229.amzn1.src  
  
x86_64:  
    kernel-debuginfo-4.14.173-106.229.amzn1.x86_64  
    kernel-4.14.173-106.229.amzn1.x86_64  
    kernel-tools-4.14.173-106.229.amzn1.x86_64  
    perf-debuginfo-4.14.173-106.229.amzn1.x86_64  
    kernel-debuginfo-common-x86_64-4.14.173-106.229.amzn1.x86_64  
    kernel-headers-4.14.173-106.229.amzn1.x86_64  
    perf-4.14.173-106.229.amzn1.x86_64  
    kernel-tools-debuginfo-4.14.173-106.229.amzn1.x86_64  
    kernel-devel-4.14.173-106.229.amzn1.x86_64  
    kernel-tools-devel-4.14.173-106.229.amzn1.x86_64  

Additional References

Red Hat: CVE-2020-10942, CVE-2020-2732, CVE-2020-27418, CVE-2020-8648

Mitre: CVE-2020-10942, CVE-2020-2732, CVE-2020-27418, CVE-2020-8648

How to protect your server from attacks?

7.1 High

CVSS3

Attack Vector

LOCAL

Attack Complexity

LOW

Privileges Required

LOW

User Interaction

NONE

Scope

UNCHANGED

Confidentiality Impact

HIGH

Integrity Impact

NONE

Availability Impact

HIGH

CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:H

6.9 Medium

AI Score

Confidence

High

5.4 Medium

CVSS2

Access Vector

LOCAL

Access Complexity

MEDIUM

Authentication

NONE

Confidentiality Impact

NONE

Integrity Impact

PARTIAL

Availability Impact

COMPLETE

AV:L/AC:M/Au:N/C:N/I:P/A:C

0.001 Low

EPSS

Percentile

30.7%

Related for ALAS-2020-1360