Critical: nspr

2014-09-19T11:38:00
ID ALAS-2014-384
Type amazon
Reporter Amazon
Modified 2014-09-19T11:38:00

Description

Issue Overview:

Mozilla Netscape Portable Runtime (NSPR) before 4.10.6 allows remote attackers to execute arbitrary code or cause a denial of service (out-of-bounds write) via vectors involving the sprintf and console functions.

Affected Packages:

nspr

Issue Correction:
Run yum update nspr to update your system.

New Packages:

i686:  
    nspr-debuginfo-4.10.4-1.22.amzn1.i686  
    nspr-4.10.4-1.22.amzn1.i686  
    nspr-devel-4.10.4-1.22.amzn1.i686

src:  
    nspr-4.10.4-1.22.amzn1.src

x86_64:  
    nspr-4.10.4-1.22.amzn1.x86_64  
    nspr-debuginfo-4.10.4-1.22.amzn1.x86_64  
    nspr-devel-4.10.4-1.22.amzn1.x86_64