Lucene search

K
amazonAmazonALAS-2012-041
HistoryFeb 02, 2012 - 4:10 p.m.

Critical: php

2012-02-0216:10:00
alas.aws.amazon.com
30

CVSS2

7.5

Attack Vector

NETWORK

Attack Complexity

LOW

Authentication

NONE

Confidentiality Impact

PARTIAL

Integrity Impact

PARTIAL

Availability Impact

PARTIAL

AV:N/AC:L/Au:N/C:P/I:P/A:P

EPSS

0.875

Percentile

98.7%

Issue Overview:

It was discovered that the fix for CVE-2011-4885 introduced an uninitialized memory use flaw. A remote attacker could send a specially-crafted HTTP request to cause the PHP interpreter to crash or, possibly, execute arbitrary code.

Affected Packages:

php

Issue Correction:
Run yum update php to update your system.

New Packages:

i686:  
    php-pgsql-5.3.10-1.15.amzn1.i686  
    php-mbstring-5.3.10-1.15.amzn1.i686  
    php-pdo-5.3.10-1.15.amzn1.i686  
    php-mcrypt-5.3.10-1.15.amzn1.i686  
    php-mysqlnd-5.3.10-1.15.amzn1.i686  
    php-mysql-5.3.10-1.15.amzn1.i686  
    php-snmp-5.3.10-1.15.amzn1.i686  
    php-odbc-5.3.10-1.15.amzn1.i686  
    php-intl-5.3.10-1.15.amzn1.i686  
    php-bcmath-5.3.10-1.15.amzn1.i686  
    php-soap-5.3.10-1.15.amzn1.i686  
    php-imap-5.3.10-1.15.amzn1.i686  
    php-debuginfo-5.3.10-1.15.amzn1.i686  
    php-cli-5.3.10-1.15.amzn1.i686  
    php-dba-5.3.10-1.15.amzn1.i686  
    php-embedded-5.3.10-1.15.amzn1.i686  
    php-mssql-5.3.10-1.15.amzn1.i686  
    php-5.3.10-1.15.amzn1.i686  
    php-process-5.3.10-1.15.amzn1.i686  
    php-ldap-5.3.10-1.15.amzn1.i686  
    php-tidy-5.3.10-1.15.amzn1.i686  
    php-common-5.3.10-1.15.amzn1.i686  
    php-devel-5.3.10-1.15.amzn1.i686  
    php-xmlrpc-5.3.10-1.15.amzn1.i686  
    php-xml-5.3.10-1.15.amzn1.i686  
    php-gd-5.3.10-1.15.amzn1.i686  
    php-fpm-5.3.10-1.15.amzn1.i686  
    php-pspell-5.3.10-1.15.amzn1.i686  
  
src:  
    php-5.3.10-1.15.amzn1.src  
  
x86_64:  
    php-pspell-5.3.10-1.15.amzn1.x86_64  
    php-imap-5.3.10-1.15.amzn1.x86_64  
    php-tidy-5.3.10-1.15.amzn1.x86_64  
    php-pdo-5.3.10-1.15.amzn1.x86_64  
    php-process-5.3.10-1.15.amzn1.x86_64  
    php-xml-5.3.10-1.15.amzn1.x86_64  
    php-pgsql-5.3.10-1.15.amzn1.x86_64  
    php-mbstring-5.3.10-1.15.amzn1.x86_64  
    php-soap-5.3.10-1.15.amzn1.x86_64  
    php-cli-5.3.10-1.15.amzn1.x86_64  
    php-debuginfo-5.3.10-1.15.amzn1.x86_64  
    php-mysql-5.3.10-1.15.amzn1.x86_64  
    php-common-5.3.10-1.15.amzn1.x86_64  
    php-odbc-5.3.10-1.15.amzn1.x86_64  
    php-5.3.10-1.15.amzn1.x86_64  
    php-bcmath-5.3.10-1.15.amzn1.x86_64  
    php-gd-5.3.10-1.15.amzn1.x86_64  
    php-dba-5.3.10-1.15.amzn1.x86_64  
    php-intl-5.3.10-1.15.amzn1.x86_64  
    php-ldap-5.3.10-1.15.amzn1.x86_64  
    php-embedded-5.3.10-1.15.amzn1.x86_64  
    php-mcrypt-5.3.10-1.15.amzn1.x86_64  
    php-snmp-5.3.10-1.15.amzn1.x86_64  
    php-devel-5.3.10-1.15.amzn1.x86_64  
    php-fpm-5.3.10-1.15.amzn1.x86_64  
    php-xmlrpc-5.3.10-1.15.amzn1.x86_64  
    php-mssql-5.3.10-1.15.amzn1.x86_64  
    php-mysqlnd-5.3.10-1.15.amzn1.x86_64  

Additional References

Red Hat: CVE-2012-0830

Mitre: CVE-2012-0830

CVSS2

7.5

Attack Vector

NETWORK

Attack Complexity

LOW

Authentication

NONE

Confidentiality Impact

PARTIAL

Integrity Impact

PARTIAL

Availability Impact

PARTIAL

AV:N/AC:L/Au:N/C:P/I:P/A:P

EPSS

0.875

Percentile

98.7%