Bitbucket Path Traversal / Remote Code Execution Vulnerability

2019-05-24T00:00:00
ID 1337DAY-ID-32793
Type zdt
Reporter Atlassian
Modified 2019-05-24T00:00:00

Description

Bitbucket Data Center had a path traversal vulnerability in the Data Center migration tool. A remote attacker with authenticated user with admin permissions can exploit this path traversal vulnerability to write files to arbitrary locations which can lead to remote code execution on systems that run a vulnerable version of Bitbucket Data Center. Bitbucket Server versions without a Data Center license are not vulnerable to this vulnerability. Versions of Bitbucket Server starting with 5.13.0 before 5.13.6 (the fixed version for 5.13.x), from 5.14.0 before 5.14.4 (fixed version for 5.14.x), from 5.15.0 before 5.15.3 (fixed version for 5.13.x), from 6.0.0 before 6.0.3 (fixed version for 6.0.x), and from 6.1.0 before 6.1.2 (the fixed version for 6.1.x) are affected by this vulnerability.

                                        
                                            CVE ID:

* CVE-2019-3397.


Product: Bitbucket Server.

Affected Bitbucket Server product versions:

5.13.0 <= version < 5.13.5
5.14.0 <= version < 5.14.3
5.15.0 <= version < 5.5.2
6.0.0 <= version < 6.0.3
6.1.0 <= version < 6.1.1


Fixed Bitbucket Server product versions:

* for 5.13.x, Bitbucket Server 5.13.5 has been released with a fix for this
issue.
* for 5.14.x, Bitbucket Server 5.14.3 has been released with a fix for this
issue.
* for 5.15.x, Bitbucket Server 5.5.2 has been released with a fix for this
issue.
* for 6.0.x, Bitbucket Server 6.0.3 has been released with a fix for this
issue.
* for 6.1.x, Bitbucket Server 6.1.1 has been released with a fix for this
issue.


Summary:
This advisory discloses a critical severity security vulnerability. Versions of
Bitbucket Server starting with 5.13.0 before 5.13.6 (the fixed version for
5.13.x), from 5.14.0 before 5.14.4 (fixed version for 5.14.x), from 5.15.0
before 5.15.3 (fixed version for 5.13.x), from 6.0.0 before 6.0.3 (fixed version
for 6.0.x), and from 6.1.0 before 6.1.2 (the fixed version for 6.1.x)  are
affected by this vulnerability.



Customers who have upgraded Bitbucket Server to version 5.13.6 or 5.14.4 or
5.15.3 or 6.0.3 or 6.1.2 are not affected.

Customers who have downloaded and installed Bitbucket Server >= 5.13.0 but less
than 5.13.5 (the fixed version for 5.13.x) or who have downloaded and installed
Bitbucket Server >= 5.14.0 but less than 5.14.3 (the fixed version for 5.14.x)
or who have downloaded and installed Bitbucket Server >= 5.15.0 but less than
5.5.2 (the fixed version for 5.15.x) or who have downloaded and installed
Bitbucket Server >= 6.0.0 but less than 6.0.3 (the fixed version for 6.0.x) or
who have downloaded and installed Bitbucket Server >= 6.1.0 but less than 6.1.1
(the fixed version for 6.1.x) please upgrade your Bitbucket Server installations
immediately to fix this vulnerability.



Path traversal in the migration tool RCE (CVE-2019-3397)

Severity:
Atlassian rates the severity level of this vulnerability as critical, according
to the scale published in our Atlassian severity levels. The scale allows us to
rank the severity as critical, high, moderate or low.
This is our assessment and you should evaluate its applicability to your own IT
environment.


Description:

Bitbucket Data Center had a path traversal vulnerability in the Data Center
migration tool. A remote attacker with authenticated user with admin permissions
can exploit this path traversal vulnerability to write files to arbitrary
locations which can lead to remote code execution on systems that run a
vulnerable version of Bitbucket Data Center. Bitbucket Server versions without a
Data Center license are not vulnerable to this vulnerability.
Versions of Bitbucket Server starting with 5.13.0 before 5.13.6 (the fixed
version for 5.13.x), from 5.14.0 before 5.14.4 (fixed version for 5.14.x), from
5.15.0 before 5.15.3 (fixed version for 5.13.x), from 6.0.0 before 6.0.3 (fixed
version for 6.0.x), and from 6.1.0 before 6.1.2 (the fixed version for 6.1.x)
are affected by this vulnerability. This issue can be tracked at:
https://jira.atlassian.com/browse/BSERV-11706 .



Fix:

To address this issue, we've released the following versions containing a fix:

* Bitbucket Server version 5.13.6
* Bitbucket Server version 5.14.4
* Bitbucket Server version 5.15.3
* Bitbucket Server version 6.0.3
* Bitbucket Server version 6.1.2

Remediation:

Upgrade Bitbucket Server to version 6.1.2 or higher.

The vulnerabilities and fix versions are described above. If affected, you
should upgrade to the latest version immediately.

If you are running Bitbucket Server 5.13.x and cannot upgrade to 6.1.2, upgrade
to version 5.13.5.
If you are running Bitbucket Server 5.14.x and cannot upgrade to 6.1.2, upgrade
to version 5.14.3.
If you are running Bitbucket Server 5.15.x and cannot upgrade to 6.1.2, upgrade
to version 5.5.2.
If you are running Bitbucket Server 6.0.x and cannot upgrade to 6.1.2, upgrade
to version 6.0.3.


For a full description of the latest version of Bitbucket Server, see
the release notes found at
https://confluence.atlassian.com/display/BitbucketServer/Bitbucket+Server+release+notes.
You can download the latest version of Bitbucket Server from the download centre
found at https://www.atlassian.com/software/bitbucket/download.

#  0day.today [2019-05-24]  #