DomainMOD 4.11.01 - (assets/add/dns.php) Cross-Site Scripting Vulnerability

2019-02-15T00:00:00
ID 1337DAY-ID-32191
Type zdt
Reporter Mohammed Abdul Raheem
Modified 2019-02-15T00:00:00

Description

Exploit for php platform in category web applications

                                        
                                            # Exploit Title: DomainMOD 4.11.01 - Cross-Site Scripting
# Exploit Author: Mohammed Abdul Raheem
# Vendor Homepage: domainmod (https://domainmod.org/)
# Software Link: domainmod (https://github.com/DomainMod/DomainMod)
# Version: v4.09.03 to v4.11.01
# CVE : CVE-2018-19914
# A Stored Cross-site scripting (XSS) was discovered in DomainMod application
# versions from v4.09.03 to v4.11.01
# After logging into the Domainmod application panel, browse to the
 /assets/add/dns.php page and inject a javascript XSS payload in
Profile Name & notes fields "><img src=x onerror=alert("XSSed-By-Abdul-Kareem")>

#POC : attached here https://github.com/domainmod/domainmod/issues/87

#  0day.today [2019-02-25]  #