e107 Plugin My_Gallery 2.3 Arbitrary File Download Vulnerability

2008-03-25T00:00:00
ID 1337DAY-ID-2777
Type zdt
Reporter Jerome Athias
Modified 2008-03-25T00:00:00

Description

Exploit for unknown platform in category web applications

                                        
                                            ================================================================
e107 Plugin My_Gallery 2.3 Arbitrary File Download Vulnerability
================================================================



e107 My_Gallery Plugin Arbitrary File Download Vulnerability

Release Date: 2008-03-25
Critical: Moderately critical
Impact: Exposure of system information, Exposure of sensitive information
Where: From remote
Solution Status: Unpatched
Software: My_Gallery v2.3 (plugin for e107)

Description:

A photo gallery for e107, powered by Highslide JS script. with random
gallery menu and navigation menu.

+ User interface for uploads images
+ Pre-moderation users download
+ Control Panel, can edit the name and description, delete and move
+ New comment system, it is now the most opulent gallery
+ New Front page
+ Added BBcode and a button

Vulnerability:
Jerome Athias has discovered a vulnerability in My_Gallery plugin for
e107, which can be exploited by malicious people to disclose sensitive
information.

The vulnerability is caused due to an input validation error in
dload.php when processing arguments passed to the "file" parameter. This
can be exploited to download arbitrary files from the affected system.

The vulnerability is confirmed in version 2.3. Other versions may also
be affected.

Solution:
Edit the source code to ensure that input is properly validated.

Dork: inurl:"e107_plugins/my_gallery"


------------------------------------------------------------------
PoC:
http://target.com/e107_plugins/my_gallery/dload.php?file=dload.php

File is downloaded as a .jpg file but the PHP source code can be
retrieved using a text editor.




#  0day.today [2016-04-20]  #