Adobe Flash Player 23.0.0.162 - '.SWF' ConstantPool Critical Memory Corruption

2016-10-12T00:00:00
ID 1337DAY-ID-25507
Type zdt
Reporter COSIG
Modified 2016-10-12T00:00:00

Description

Exploit for multiple platform in category dos / poc

                                        
                                            #####################################################################################
 
# Application: Adobe Flash Player
# Platforms: Windows,OSX
# Versions: 23.0.0.162 and earlier
# Author: Francis Provencher of COSIG
# Website: https://cosig.gouv.qc.ca/en/advisory/
# Twitter: @COSIG_
# Date: October 11, 2016
# CVE-2016-4273
# COSIG-2016-35
 
#####################################################################################
 
1) Introduction
2) Report Timeline
3) Technical details
4) POC
 
#####################################################################################
 
================
1) Introduction
================
 
Adobe Flash Player (labeled Shockwave Flash in Internet Explorer and Firefox) is a freeware software for using content created
on the Adobe Flash platform, including viewing multimedia, executing rich Internet applications, and streaming video and audio.
Flash Player can run from a web browser as a browser plug-in or on supported mobile devices.[7] Flash Player was created by Macromedia
and has been developed and distributed by Adobe Systems since Adobe acquired Macromedia.
 
(https://en.wikipedia.org/wiki/Adobe_Flash_Player)
 
#####################################################################################
 
============================
2) Rapport de Coordination
============================
 
2016-05-17: Francis Provencher of COSIG report this vulnerability to Adobe PSIRT;
2016-05-23: Adobe PSIRT confirm this vulnerability;
2016-10-11: Adobe publish a patch (APSB16-32);
2016-10-11: Advisory released by COSIG;
 
#####################################################################################
 
=====================
3) Technical details
=====================
 
The vulnerability allows a remote attacker to execute malicious code or access to a part of the dynamically allocated memory using a user interaction
visiting a Web page or open a specially crafted SWF file, an attacker is able to create an “out of bound” memory corruption. A file with an “ActionRecord”
structure that contain an invalid “ConstantPool” could lead to remote code execution in the context of the current user.
 
#####################################################################################
 
===========
4) POC:
===========
 
https://cosig.gouv.qc.ca/wp-content/uploads/2016/10/COSIG-2016-35.zip
https://github.com/offensive-security/exploit-database-bin-sploits/raw/master/sploits/40510.zip
 
####################################################################################

#  0day.today [2018-04-03]  #