Jamroom 5.2.6 Cross Site Scripting Vulnerability

2014-08-14T00:00:00
ID 1337DAY-ID-22518
Type zdt
Reporter High-Tech Bridge
Modified 2014-08-14T00:00:00

Description

Exploit for php platform in category web applications

                                        
                                            Product: Jamroom
Vendor: Talldude Networks, LLC
Vulnerable Version(s): 5.2.6 and probably prior
Tested Version: 5.2.6
Advisory Publication: July 23, 2014 [without technical details]
Vendor Notification: July 23, 2014
Vendor Patch: July 23, 2014
Public Disclosure: August 13, 2014
Vulnerability Type: Cross-Site Scripting [CWE-79]
CVE Reference: CVE-2014-5098
Risk Level: Medium
CVSSv2 Base Score: 4.3 (AV:N/AC:M/Au:N/C:N/I:P/A:N)
Solution Status: Fixed by Vendor
Discovered and Provided: High-Tech Bridge Security Research Lab ( https://www.htbridge.com/advisory/ )

-----------------------------------------------------------------------------------------------

Advisory Details:

High-Tech Bridge Security Research Lab discovered vulnerability in Jamroom, which can be exploited to perform Cross-Site
Scripting (XSS) attacks.


1) Reflected Cross-Site Scripting (XSS) in Jamroom: CVE-2014-5098

The vulnerability exists due to insufficient sanitization of user-supplied data after the "/search/results/"
URI. A remote attacker can trick a logged-in user to open a specially crafted link and execute arbitrary HTML and script
code in browser in context of the vulnerable website.

The exploitation example below uses the "alert()" JavaScript function to display "immuniweb" word:

http:///search/results/?=%22onmouseover%3d%27alert%28%22immuniweb%22%29%27bad%3d%22%3E



-----------------------------------------------------------------------------------------------

Solution:

Update Jamroom Search module to 1.2.2 version.

More Information:
https://www.jamroom.net/the-jamroom-network/networkmarket/43/search?expanded_changelog=1

#  0day.today [2018-02-06]  #