Cisco Linksys E1200 / N300 Cross Site Scripting Vulnerability

ID 1337DAY-ID-20713
Type zdt
Reporter Carl Benedict
Modified 2013-04-30T00:00:00


Cisco Linksys E1200 and N300 routers version 2.0.04 suffer from a cross site scripting vulnerability.

Software  : Cisco/Linksys Router OS  
Hardware : E1200 N300 (others currently untested)
Version   : 2.0.04 (others currently untested)
Website   :
Issue     :  Reflected XSS
Severity  : Medium
Researcher: Carl Benedict (theinfinitenigma)

Product Description
The Cisco/Linksys E1200 N300 is a consumer-grade router, wireless access point, and 10/100 switch. 

The apply.cgi page, which backs all HTML forms on the device, is vulnerable to reflected XSS via the 'submit_button' parameter. The vulnerability is caused due to a lack of input validation and poor/missing server side validation checks. This attack requires an authenticated session. This application uses HTTP basic authentication. Because of this, there is no session, which increases the likelihood of this attack being successful. 

Sample URL #1 (HTTP GET request):

Sample URL #2 (HTTP GET request):

04/26/2013 : Discovery
04/27/2013 : Advisory released

# [2018-01-05]  #