Siche Search v.0.5 Zerboard Multiple Web Vulnerabilities

2012-04-14T00:00:00
ID 1337DAY-ID-18062
Type zdt
Reporter Benjamin K.M.
Modified 2012-04-14T00:00:00

Description

Exploit for php platform in category web applications

                                        
                                            Title:
======
Siche Search v.0.5 Zerboard - Multiple Web Vulnerabilities

Introduction:
=============
Siche search v.0.5 for Zerboard is search module to known CMS named Zeroboard

(Copy of the Vendor Homepage: http://eos.pe.kr )


Abstract:
=========
A Vulnerability Laboratory researcher discovered multiple web vulnerabilities in Siches Search v.0.5 Application for
Zerboard.

Details:
========
1.1
Multiple SQL Injection vulnerabilities are detected in Siches Search v.0.5 for Zerboard.
The vulnerability allows an attacker (remote) or local low privileged user account to inject/execute own sql commands
on the affected application dbms. Successful exploitation of the vulnerability results in dbms & application
compromise.

Vulnerable Module(s):
[+] ssearch.php


1.2
Multiple non persistent cross site scripting vulnerability is detected in Siches Search v.0.5 for Zerboard.
The vulnerability allows remote attackers to hijack website customer, moderator or admin sessions with high required
user inter action or local low privileged user account. Successful exploitation can result in account steal, phishing
& client-side content request manipulation.


Vulnerable Module(s):
[+] ssearch - category=&ss=1&search=


Proof of Concept:
=================
1.1
The sql injection vulnerabilities can be exploited by remote attackers without user inter action.
For demonstration or reproduce ...

PoC:
ssearch.php?sno=2&siche=search&page=1&sn=`[SQL Injection]&ss=`1[SQL Injection]&sm=`1&search=asd

ssearch.php?sno=1&siche=search&page=5&sn=1&ss=1&sm=1&sc=&oga=&search=hey&align=`[SQL
Injection]

ssearch.php?sno=1&siche=search&page=5&sn=1&ss=1&sm=1&sc=&oga=&search=hey&
align=mt.subject&align1=ASC&category=`[SQL Injection]

1.2
The persistent script code inject can be exploited by remote attackers with medium required user inter action.

PoC:
ssearch.php?PHPSESSID=686a65552114b3d0e70c461c4c531e99&sno=1&siche=search&page=1&category=
&ss=1&search=<script>alert(vlab)</script>



#  0day.today [2018-01-10]  #