Mozilla Firefox Language Pack XUL Injection Sandbox Escape Vulnerability

2019-07-10T00:00:00
ID ZDI-19-657
Type zdi
Reporter Niklas Baumstark (@_niklasb)
Modified 2019-06-22T00:00:00

Description

This vulnerability allows remote attackers to escape the sandbox on affected installations of Mozilla Firefox. An attacker must first obtain the ability to execute low-privileged code on the target system in order to exploit this vulnerability. The specific flaw exists due to possibility of XUL injection via language pack. An attacker can leverage this vulnerability to escape the sandbox and execute code at medium integrity.