Advantech WebAccess webvrpcs drawsrv Untrusted Pointer Dereference Remote Code Execution Vulnerability

2017-12-06T00:00:00
ID ZDI-17-940
Type zdi
Reporter Steven Seeley (mr_me) of Offensive Security
Modified 2017-12-06T00:00:00

Description

This vulnerability allows remote attackers to execute arbitrary code on vulnerable installations of Advantech WebAccess. Authentication is not required to exploit this vulnerability.

The specific flaw exists within the implementation of the 0x2775 IOCTL in the webvrpcs process. The issue results from the lack of proper validation of a user-supplied value prior to dereferencing it as a pointer. An attacker can leverage this functionality to execute code under the context of Administrator.