Foxit Reader XFA gotoURL Command Injection Remote Code Execution Vulnerability

2017-09-06T00:00:00
ID ZDI-17-718
Type zdi
Reporter Steven Seeley (mr_me) of Offensive Security
Modified 2017-09-07T00:00:00

Description

This vulnerability allows remote attackers to execute arbitrary code on vulnerable installations of Foxit Reader. User interaction is required to exploit this vulnerability in that the target must visit a malicious page or open a malicious file.

The specific flaw exists within the gotoURL method. The issue results from the lack of proper validation of a user-supplied string before using it to execute a system call. An attacker can leverage this vulnerability to execute code under the context of the current process.