Dell SonicWALL Universal Management Suite ImagePreviewServlet SQL Injection Remote Code Execution Vulnerability

2016-12-02T00:00:00
ID ZDI-16-617
Type zdi
Reporter rgod
Modified 2016-12-02T00:00:00

Description

This vulnerability allows remote attackers to execute arbitrary code on vulnerable installations of Dell SonicWALL Universal Management Suite. Authentication is not required to exploit this vulnerability.

The specific flaw exists within the ImagePreviewServlet servlet. A SQL Injection vulnerability exists in processing of the logoID parameter. An attacker can leverage this vulnerability to execute arbitrary code in the context of SYSTEM.