Samsung Security Manager ActiveMQ Broker Service PUT Method Remote Code Execution Vulnerability

2016-08-18T00:00:00
ID ZDI-16-481
Type zdi
Reporter rgod
Modified 2016-11-09T00:00:00

Description

This vulnerability allows remote attackers to execute arbitrary code on vulnerable installations of Samsung Security Manager. Authentication is not required to exploit this vulnerability.

The specific flaw exists within the ActiveMQ Broker service that is installed as part of this product. By issuing an HTTP PUT request, an attacker can create an arbitrary file on the server with attacker controlled data. An attacker can further leverage this vulnerability to execute code on the server as SYSTEM.