BitTorrent API Cross Site Scripting Remote Code Execution Vulnerability

2016-05-20T00:00:00
ID ZDI-16-353
Type zdi
Reporter lokihardt
Modified 2016-11-09T00:00:00

Description

This vulnerability allows remote attackers to execute arbitrary code on vulnerable installations of BitTorrent and uTorrent. User interaction is required to exploit this vulnerability in that the target must visit a malicious page or open a malicious file.

These applications expose a web service locally on port 10000. An attacker can use a cross site scripting vulnerability in this web service to obtain a credential allowing full access to the web service. An attacker can leverage this to execute code under the context of the current user.