Advantech WebAccess webvrpcs Service BwpAlarm.dll memcpy Globals Overflow Remote Code Execution Vulnerability

2016-02-05T00:00:00
ID ZDI-16-074
Type zdi
Reporter Anonymous
Modified 2016-11-09T00:00:00

Description

This vulnerability allows remote attackers to execute arbitrary code on vulnerable instances of Advantech WebAccess. Authentication is not required to exploit this vulnerability.

The specific flaw exists within the implementation of the 0x11172 IOCTL in the BwpAlarm subsystem. A globals overflow vulnerability exists in a call to memcpy. An attacker can use this vulnerability to execute arbitrary code in the context of an administrator of the system.