Adobe Reader DC AGM Heap Buffer Overflow Remote Code Execution Vulnerability

2015-11-16T00:00:00
ID ZDI-15-569
Type zdi
Reporter Jaanus Kp Clarified Security
Modified 2015-06-22T00:00:00

Description

This vulnerability allows remote attackers to execute arbitrary code on vulnerable installations of Adobe Reader DC. User interaction is required to exploit this vulnerability in that the target must visit a malicious page or open a malicious file. The specific flaw exists within AGM.dll. A specially crafted PDF with multiple layers can force a dangling pointer to be reused after it has been freed. An attacker can leverage this vulnerability to execute arbitrary code under the context of the current process.