Hewlett-Packard KeyView IDOL Lotus Parsing Remote Code Execution Vulnerability

2015-08-24T00:00:00
ID ZDI-15-400
Type zdi
Reporter ASD - Vulnerability Research
Modified 2015-11-09T00:00:00

Description

This vulnerability allows remote attackers to execute arbitrary code on vulnerable installations of Hewlett-Packard KeyView IDOL. User interaction is required to exploit this vulnerability in that the target must visit a malicious page or open a malicious file.

The flaw exists within the handling of Lotus wk1 files. It is possible to trigger a buffer overflow when handling malformed data within a Lotus wk1 file. A remote attacker could exploit this vulnerability to execute arbitrary code under the context of the process.