MICROSYS PROMOTIC Stack Buffer Overflow Remote Code Execution Vulnerability

ID ZDI-15-091
Type zdi
Reporter Anonymous
Modified 2015-11-09T00:00:00


This vulnerability allows remote attackers to execute arbitrary code on vulnerable installations of MICROSYS PROMOTIC. Authentication is not required to exploit this vulnerability.

The program blindly copies attacker-supplied data into a fixed-sized buffer without validating the length of this data resulting in a stack buffer overflow. The specific flaw exists within the PmBase64Decode function which ignores the passed-in length of the destination buffer. An attacker can exploit this condition to achieve code execution under the context of the process.