Dell ScriptLogic Asset Manager GetClientPackage SQL Injection Remote Code Execution Vulnerability

2015-02-20T00:00:00
ID ZDI-15-048
Type zdi
Reporter Andrea Micalizzi (rgod)
Modified 2015-11-09T00:00:00

Description

This vulnerability allows remote attackers to execute arbitrary code on vulnerable installations of Dell ScriptLogic Asset Manager, also known as Quest Workspace Asset Manager. Authentication is not required to exploit this vulnerability.

To exploit this security flaw, an attacker would make a specially crafted web request to a handler named GetClientPackage.aspx that is installed as part of this product. An attacker can leverage this vulnerability to execute code under the context of NETWORK SERVICE.