ManageEngine Password Manager Pro UploadAccountActivities filename Directory Traversal Denial of Service Vulnerability

2014-12-11T00:00:00
ID ZDI-14-421
Type zdi
Reporter Andrea Micalizzi (rgod)
Modified 2014-11-09T00:00:00

Description

This vulnerability allows remote attackers to create a denial of service condition on vulnerable installations of ManageEngine Password Manager Pro. Authentication is not required to exploit this vulnerability.

The specific flaw exists within the UploadAccountActivities servlet. The issue lies in the failure to properly sanitize a filename. A remote attacker can exploit this vulnerability to delete files from the system.