Sophos Cyberoam webclient_portal_settings Command Injection Remote Code Execution Vulnerability

2014-10-01T00:00:00
ID ZDI-14-332
Type zdi
Reporter agix
Modified 2014-11-09T00:00:00

Description

This vulnerability allows remote attackers to execute arbitrary code on vulnerable installations of Sophos Cyberoam. Authentication is required to exploit this vulnerability.

The specific flaw exists within the webclient_portal_settings opcode. The issue lies in the failure to properly sanitize user-supplied input before executing commands. An attacker can leverage this vulnerability to execute code under the context of the current process.