Oracle Data Quality PostcardPreviewInt onclose Remote Code Execution Vulnerability

ID ZDI-14-109
Type zdi
Reporter Andrea Micalizzi aka rgod
Modified 2014-11-09T00:00:00


This vulnerability allows remote attackers to execute arbitrary code on vulnerable installations of Oracle Data Quality. User interaction is required to exploit this vulnerability in that the target must visit a malicious page or open a malicious file.

The specific flaw exists within the TSS12.TransformerTools.PostcardPreviewInt ActiveX control. The issue lies in the ability to dereference arbitrary pointers from JavaScript. An attacker can leverage this vulnerability to execute code under the context of the current process.