Hewlett-Packard Virtual User Generator EmulationAdmin Service Information Disclosure Vulnerability

2014-04-17T00:00:00
ID ZDI-14-100
Type zdi
Reporter Andrea Micalizzi aka rgod
Modified 2014-11-09T00:00:00

Description

This vulnerability allows remote attackers to execute arbitrary code on vulnerable installations of HP Virtual User Generator. Authentication is not required to exploit this vulnerability.

The specific flaw exists within the exposed EmulationAdminSoapBinding web service. The issue lies in the handling of several methods resulting in the ability to read, write, and delete arbitrary files. An attacker can leverage this vulnerability to leak credential databases or execute code under the context of SYSTEM.