EMC Connectrix Manager Converged Network Edition FileUploadController Servlet Remote Code Execution Vulnerability

ID ZDI-13-279
Type zdi
Reporter Andrea Micalizzi aka rgod
Modified 2013-11-09T00:00:00


This vulnerability allows remote attackers to execute arbitrary code on vulnerable installations of EMC Connectrix Manager Converged Network Edition. Authentication is not required to exploit this vulnerability.

The specific flaw exists within the 'FileUploadController' servlet, which allows an unauthenticated user to upload an arbitrary file anywhere on the system. An attacker can leverage this directory traversal vulnerability into arbitrary code execution on the compromised server in the security context of the Administrator account.