HP SiteScope issueSiebelCmd SOAP Request Remote Code Execution Vulnerability

ID ZDI-13-263
Type zdi
Reporter Andrea Micalizzi aka rgod
Modified 2013-11-09T00:00:00


This vulnerability allows remote attackers to execute arbitrary code on vulnerable installations of HP SiteScope. Authentication is not required to exploit this vulnerability.

The specific flaw exists within the issueSiebelCmd() web method. A remote attacker can abuse this web method in order to remotely execute code under the context of the SYSTEM user.