Hewlett-Packard Intelligent Management Center RssServlet Information Disclosure Vulnerability

2013-04-09T00:00:00
ID ZDI-13-062
Type zdi
Reporter Andrea Micalizzi aka rgod
Modified 2013-11-09T00:00:00

Description

This vulnerability allows remote attackers to obtain sensitive information on vulnerable installations of HP Intelligent Management Center. Authentication is not required to exploit this vulnerability.

The specific flaw exists within the RssServlet servlet. This servlet suffers from a XML external entity injection vulnerability which allows any file readable by SYSTEM to be disclosed. By abusing this behavior an attacker can disclose administrative credentials and possibly leverage this situation to achieve remote code execution.