Novell GroupWise gwcls1.dll ActiveX Control Remote Code Execution Vulnerability

2013-02-01T00:00:00
ID ZDI-13-008
Type zdi
Reporter Andrea Micalizzi aka rgod
Modified 2013-11-09T00:00:00

Description

This vulnerability allows remote attackers to execute arbitrary code on vulnerable installations of Novell Groupwise. User interaction is required to exploit this vulnerability in that the target must visit a malicious page or open a malicious file.

The specific flaws exists within multiple methods exposed by gwcls1.dll. There are 20 methods which accept an XPItem pointer and perform operations on the potentially malicious pointer without validation. Additionally, the SetEngine() method accepts an unvalidated pointer and performs operations and method calls based upon it. An attacker can manipulate these behaviors to execute arbitrary code on the user's system in the context of the browser.