InduSoft WebStudio CEServer Operation 0x15 Remote Code Execution Vulnerability

2011-11-16T00:00:00
ID ZDI-11-329
Type zdi
Reporter Luigi Auriemma
Modified 2011-11-09T00:00:00

Description

This vulnerability allows remote attackers to execute arbitrary code on vulnerable installations of Indusoft WebStudio. Authentication is not required to exploit this vulnerability.

The flaw exists within the CEServer component which is used as a runtime dependency for applications deployed using Indusoft WebStudio. When handling the Remove File operation (0x15) the process blindly copies user supplied data to a fixed-length buffer on the stack. A remote attacker can exploit this vulnerability to execute
arbitrary code under the context of the browser.