Novell Netware NWFTPD.NLM DELE Remote Code Execution Vulnerability

ID ZDI-11-106
Type zdi
Reporter Francis Provencher for Protek Research Lab's
Modified 2011-11-09T00:00:00


This vulnerability allows remote attackers to execute arbitrary code on vulnerable installations of Novell Netware. Authentication is required to exploit this vulnerability.

The flaw exists within NWFTPD.NLM. When handling the argument provided to the DELE command the application copies user supplied data to a fixed length stack buffer. A remote attacker can exploit this vulnerability to execute arbitrary code under the context of the super user.